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1: INTRODUCTION  

1.1 CPET OVERVIEW  

  

cPet (CSDR Planning and Execution Tool) is designed to handle CSDR (Cost and Software 

Data Reporting) plans and cost reports. cPet deals with two main categories in viewing plans: 

importing and creating documents. Existing plans and cost reports can be imported into cPet 

and easily reviewed and edited. cPet provides warnings where data are missing or invalid. 

The importing process generates an XML version of the document. Furthermore, plans can 

be exported to PDF to resemble the DD Form 2794. 

 

Plans can also be created from scratch using cPet's editing tools. Similar to the imported 

plans, cPet generates an XML version of the new plan, and the data can be viewed in a PDF 

or Excel replica of the DD Form 2794. 

 

In addition to managing CSDR data, cPet provides an automated validation process for cost 

reports. An error log displays warnings pertaining to missing, incomplete, inconsistent, and 

numerically inaccurate data. Based on the validation results, the user can choose to accept or 

reject the report. The end product is a validation letter explaining the results. 

 

The flowchart below shows how cPet is organized into importing and creating CSDR plans, 

as well as importing and validating cost reports. 
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Proceed to Getting Started to follow a series of tutorials relating to importing, creating, and 

validating documents. 
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1.2 WHATôS NEW 

October 31, 2012 

cPet v. 2.4 Release 

_____________________________________________________________________________________________________________________________________________ 

¶ Added support for 1921-3 validation 

¶ Added support for 1921-2, including the following: 

1.  XML schema (i.e. file format) 

2.  XML import/export 

3.  Excel DD Form import/export 

4.  Graphical User Interface for viewing/editing data in cPet 

5.  1921-2 flat file import/export 

6.  1921-2 Validation 

¶ 2011 plans exported as Excel DD 2794 now paginate correctly for better printing 

formats 

¶ ñNumber of Unitsò fields now import correctly from Excel for 2011 version 1921 and 

1921-1, allowing them to be validated. 

___________________________________________ 

Updates for Version 2.3 Release, February 1, 2012 

* Added support for importing and creating new plans and cost reports of the 2011 DID 

version. 

* Contract plans can now be imported or created without the presence of a program plan 

open in cPet. 

* In previous versions of cPet, WBS elements on a contract planôs WBS Editor were 

highlighted green (by default) if the elements also appeared on the program plan. This green 

highlighting no longer occurs. 

* The ñEdit > Insert WBS from Existing Planò command on a contract planôs WBS Editor 

has slightly changed. In previous versions, this command would insert only those WBS 
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elements that were checked on the program planôs RDT. In Version 2.3, the entire program 

planôs WBS is inserted. 

* There are a few options for creating a new plan: creating a plan from scratch and cloning an 

existing plan. For a new contract plan, there is also the option to create the plan based on a 

parent plan's RDT. 

* It is not necessary to select a contractor before importing or creating a contract plan. 

* There is a single menu item to import or create a contract plan or subcontract plan. For 

2007 and 2011 documents, users can change the Plan Type to ñSubcontractò in the Basic Info 

window to differentiate from the Prime Contract. 

* The ñContract Informationò tab is added to the Basic Info window for contract plans. This 

tab includes information such as the contract number, contractor name, organization, 

division, and (for the 2011 version) the appropriation and DD 1921-3 required report check 

box. 

* Added support for importing a contractorôs name, division, and location from the DD 2794 

Excel file. Users do not have to select a contractor in cPet before importing a contract plan. 

* When a new contract plan is created, the contractor name will appear as ñTBDò until the 

user updates the name under View > Contractors. 

* Provided the option to set the WBS System Type to MIL-HDBK-881A or MIL-STD-881C. 

* Added support for importing 1921-3s. 

* Added new validation rules for 1921s: 

- The contract price must be a number, empty, or "N/A." 

- The contract ceiling must be a number, empty, or "N/A." 

- The summary element "Reporting Contractor FCCM" must have a non-zero Total At 

Completion cost. 

- The Systems Engineering/Program Management WBS element must have a non-zero Total 

At Completion cost. 

- If the Report Cycle on the 1921 Basic Info is marked as "Final," then the summary element 

"Reporting Contractor Undistributed Budget" Total At Completion cost must be zero. 

- If the Report Cycle on the 1921 Basic Info is marked as "Final," then the summary element 

"Reporting Contractor Management Reserve" Total At Completion cost must be zero. 
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- If the Report Cycle on the 1921 Basic Info is marked as "Final," then the summary element 

"Total Price" Total To Date cost must be at least 95% of the Total At Completion cost. 

- If the Report Cycle on the 1921 Basic Info is marked as "Final," then the root element (e.g. 

top level element) To Date cost must be at least 95% of the At Completion cost. This rule 

applies to Nonrecurring, Recurring, and Total costs. 

- The Total Price at Completion should equal the Contract Price. However, if the Contract 

Ceiling is provided, then the Total Price should be between the Contract Price and Contract 

Ceiling. If neither of these scenarios is true, then Remarks should be reported. 

* Added new validation rules for 1921-1s: 

- If there are costs on Line 18 "Total Direct-Reporting Subcontractor Dollars," then an 

explanation should be provided in the Remarks section.   

- If Line 20 ñOther Costs Not Shown Elsewhereò is greater than or equal to x% of Line 21 

ñTotal Cost,ò then an explanation should be provided in the Remarks section (the actual 

percentage depends on the document version). 

* Added command to update 2007 cost reports to 2011 versions 

* Updated validation memo 

* Updated the Narrative Text default headings for contract plans to be: 

- Non-Recurring/Recurring Definitions 

- Cost Accounting Standards (CAS) Disclosure Statement Differences 

- 1921-3 Contractor Business Data Report 

- ** (if required) 1921-2 Progress Curve Report 

* Treat WBS elements whose siblings are all N/A as single child elements. One validation 

condition is that an element should not be the single child of another element. The definition 

of "single child" is broadened to include any non-N/A element whose siblings are all N/A. 

Updates for Version 2.2 Interim Release, January 7, 2011 

* Added support for importing 2007 Excel files (xlsx). 

* Removed warning from 1921 validation: "Non-required reporting element omitted from 

1921." 

* Added 1921 and 1921-1 validation warning that flags negative figures. 

Updates for Version 2.2, Nov 2009 



cPet Help Manual 

6 

* Added a new ñFlat Fileò import/export feature. Data can now be imported from a standard 

flat file format into cPet. Also, data already read into cPet can be exported into the flat file 

format. 

* The Program Name for contract plans is now editable within cPet. 

* Added a new validation rule for 1921ôs: cPet will report a warning if there is zero cost in 

the Total At Completion column for either the ñReporting Contractor G&Aò summary 

element or the ñReporting Contractor Profit/Loss or Feeò summary element. 

* Updated 2003 DD 1921-1 quantity validation. 

* Removed document-level Remarks field from Basic Info of 1921-1. Added Remarks field 

for each WBS Element on the Cost Data of the 1921-1. 

Updates for Version 2.1, Jun 2, 2009 

* Added functionality to export a 1921 and a 1921-1 to Excel 

* Added 1921 and 1921-1 Cost Report Comparison feature 

* Added import warnings for missing summary elements on plans 

* Added Cut/Copy/Paste commands in WBS Editor. WBS Elements can be pasted in Excel, 

and likewise, elements from Excel can be pasted in the WBS Editor 

* Added ñFree Edit Modeò in WBS Editor. In Free Edit Mode, parent/child relationships 

among WBS elements are relaxed so that individual elements can be indented and moved 

without changing the indentation or position of other elements. 

Updates for 2.0 Production Jan 13, 2009 

* Moved fields for Total Est. Contract Value and Software Contract Value from the Basic 

Info to the RDT. This change relates to both the program plan and the contract plan. 

* On DD 2794 plan exports, the N/A will now appear in the 1921 column (instead of the 

CWBS column) for WBS elements that do not require cost reports. 

* Added a warning for blank contract numbers in the Conversion Results when importing 

contract plans. 

* Added up/down toolbar buttons in the Narrative Text on the plan Basic Info windows. 

* Added Expand/Collapse All commands to the WBS Editor. 

* Modified the DD 2794 Excel export so that text in fields such as the Preparing 

Organization wrap. 
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Updates for 2.0 Beta Nov 5, 2008 

* Fixed tools used to create a 1921/1921-1 Excel template. The user can now export the cost 

data from a 1921/1921-1 to an Excel template, which can readily be imported into cPet. See 

the updated help topics ñCreating a 1921ò and ñCreating a 1921-1ò for details (found under 

Tutorials>Cost Reports). 

* Changed summary element validation for 2003 1921.  If all the subcontractor summary 

elements are blank/zero, then [Root WBS Element] = Total Cost (Less Reporting Contractor 

G&A & Profit or Fee). See the help topic ñValidation Rulesò for more information. 

* Changed 1921 validation results to include WBS element code for the error, ñChild 

elements do not sum to parent element correctly.ò 

 

1.3 GETTING STARTED  

Once cPet opens, the main screen is displayed: 

  

 

  

There are a few recommendations to getting started: 

  

Import an Excel-based Program or Contract Plan by selecting File > Import 
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Create a new Program or Contract Plan by selecting File > New 

Open an existing cPet document by selecting File > Open 

Drag and drop cPet files from Windows Explorer into this window 

Select Help to access the built-in Help System 

  

Perhaps the best way to familiarize yourself with cPet is to first import plans, and then create 

new plans. 

  

Proceed to Importing a Program Plan to start. 
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2: TUTORIALS  

2.1 IMPORTING EXISTING P LANS 

2.1.1 IMPORTING A PROGRAM PLAN 

The Import Program Plan command is used to convert DD 2794 Excel files into XML files 

that can then be reviewed and edited in cPet. To import a program plan, start with this 

tutorial and then follow the successive tutorials as listed below: 

  

Viewing the Basic Information 

Viewing the WBS Editor 

Viewing the Submission Events 

  

In the main window of cPet, click File > Import > Import DD 2794 (Program Plan). 

  

 

  

  

Select the file you want to import and click ñOpen.ò 
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Tip: You can import files that use either Excel 2003 (with an xls extension) or Excel 2007 

(with an xlsx extension). 

  

Tip: You must select a program plan that uses the 2003, 2007, or 2011 DD2794 format. 

The plan in this example uses the 2011 format. 

  

 

  

Wait while the file imports. 
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Once the file has finished importing, the Conversion Results window opens. 

  

 

  

  

The green checks   indicate that the data imported correctly, and the yellow warnings   

 indicate errors. Review these Conversion Results to anticipate some of the problems that 

will be seen when comparing the Excel file to the data which imported into cPet. 
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The imported file now appears in the main screen of cPet. 

  

There are three main components of viewing a plan: The Basic Info, WBS Editor, and 

Submission Events. 

  

 

  

Proceed to Viewing the Basic Information  to begin reviewing the program plan. 

  

  

2.1.2 VIEWING THE BASIC IN FORMATION  

This tutorial is step one in the three-step process of importing a program plan: 

  

­ 1. View the Basic Information 

     2. View the WBS Editor 

     3. View the Submission Events 
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This tutorial will take you through the first of these steps ï viewing the Basic Information. 

  

Click the  icon to view the Basic Info. 

  

 

  

Verify that all the header information imported correctly into cPet. 

  

Click on the ñDD2794 Narrative Textò tab of the Basic Info window. 

  



cPet Help Manual 

14 

 

  

Enter the text found in the remarks sections at the bottom of the DD 2794. This field will not 

import; the text must be entered manually or copied and pasted from the source. 

  

Default headings are provided ( ñProgram Overview,ò ñContracting Approach,ò and 

ñQuantity Overviewò for a program plan). However, headings can be added or modified 

using the following icons: 

  

Add a new parent heading 

Add a new sibling heading 

Add a new child heading 

Move entry up on the list 

Move entry down on the list 

Delete the heading 

  

Tip: Images will not copy into the Narrative Text. This window is strictly text only. 
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Tip: The "proper" way to organize the Narrative Text is to have a parent header, followed 

by a child header, followed by the actual descriptive text. For instance, the layout of the 

Narrative Text should be as follows: 

  

Parent Header 

Child Header 

Descriptive Text 

  

Do not type information directly under the first two headers. If you do not follow the above 

layout, the text will not be properly formatted in the Remarks section when exported to PDF 

or Excel. 

  

Save and close the Basic Info window. 

  

Proceed to Viewing the WBS Editor. 

  

  

2.1.3 VIEWING THE WBS EDIT OR 

This tutorial is step two in the three-step process of importing a program plan: 

  

     1. View the Basic Information 

­ 2. View the WBS Editor 

     3. View the Submission Events 

  

Click on the  icon in the main window of cPet to view the WBS Editor. 
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View the WBS Editor and verify that each WBS Element has the appropriate form checked. 

  

 

  

Alterations to the WBS Editor (such as adding or moving a WBS element) are discussed in 

the tutorial Editing the WBS Editor. 

  



Tutorials 

17 

Continue reviewing the imported program plan by proceeding to Viewing the Submission 

Events. 

  

  

2.1.4 VIEWING THE SUBMISSI ON EVENTS 

This tutorial is step three in the three-step process of importing a program plan: 

  

     1. View the Basic Information 

     2. View the WBS Editor 

­ 3. View the Submission Events 

  

Click on the   icon to view the Submission Events. 

  

 

  

View the Submission events and verify that the correct forms are checked and the dates have 

imported. 
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Making changes to the Submission Events window is discussed in the tutorial Editing the 

Submission Events. 

  

You have now finished reviewing your imported plan. Continue to Importing a Contract Plan 

for the tutorial on how to import a contract plan. 

  

2.1.5 IMPORTING A CONTRACT  PLAN 

In the main window of cPet, click File > Import > Import DD 2794 (Contract/Subcontract 

Plan). 

  

Tip: It is not necessary to have a program plan open in cPet before importing a contract 

plan. In this tutorial, however, we did already import a program plan. 
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Select the contract plan to be imported and click ñOpen.ò 

  

Tip: You can import files that use either Excel 2003 (with an xls extension) or Excel 2007 

(with an xlsx extension). 

  

Tip: You must select a contract plan that uses the 2003, 2007, or 2011 DD2794 format. 

The plan in this example uses the 2011 format. 
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Wait for the file to import. 

  

The Conversion Results are displayed. Review these results to be aware of importing 

problems. 
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The image below shows both the program plan and contract plan that have been imported 

into cPet. If you wish to indent the contract plan under the program plan, you can drag and 

drop the contract plan. This action will link the documents. 
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View the Basic Information, WBS Editor, and Submission Events of the contract plan as you 

did for the program plan. 

  

Note that the plan type will be marked "Prime Contract" according to the DD 2794 Excel file. 

  

 

  

Notice that compared to the program plan, the Contract Plan Basic Info has an additional tab 

- the Contract Informatio n. 

  

The Contract Information tab is shown below. 
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The Contractor Name, Division, and Location are imported if they are on separate lines in the 

Excel file. For 2011 contract plans, the Organization and the Division are broken out into 

separate fields. 

  

 

  

For 2003 and 2007 contract plans, the contractor name, division, and location should appear 

as follows: 
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You should also check that the contractor appears correctly in the Contractor Selection 

Dialog. 

  

Donôt forget to write remarks in the Narrative Text tab of the Basic Info window. The default 

headings for contract plans are: 

  

- Non-Recurring/Recurring Definitions 

- Cost Accounting Standards (CAS) Disclosure Statement Differences 

- 1921-3 Contractor Business Data Report 

- ** (if required) 1921-2 Progress Curve Report 

  

Importing a subcontract plan is nearly identical to importing a contract plan. Proceed to the 

Importing a Subcontract Plan tutorial to see the difference. 

  

  

2.1.6 IMPORTING A SUBCONTR ACT PLAN  

Importing a subcontract plan is a lot like importing a contract plan. 

  

Tip: It is not necessary to have a program plan or prime contract plan open in cPet before 

importing a subcontract plan. In this tutorial, however, we did already import a program 

plan and prime contract plan. 

  

In the main window of cPet, click File > Import > Import DD 2794 (Contract/Subcontract 

Plan). Select the subcontract plan to import. Proceed as you did for the Importing a Contract 

Plan tutorial. 
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For 2007 and 2011 documents, cPet will recognize the Plan Type as subcontract according to 

the Excel File. 

  

 

  

The subcontract plan will have a different icon than the contract plan in cPet's main window. 

  

 

  

  

Once you are comfortable with importing plans, try building a plan from scratch using cPet's 

tools. Start with the Creating a Program Plan tutorial. 

  

  

2.1.7  LINKING DOCUMENTS  

The Linking Documents tool provides a way to link plans or cost reports together. 
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If plans have already been imported into cPet but a contract plan is not associated with a 

particular program plan, for example, then the linking tool is helpful. 

  

In the main window of cPet, click Tools > Link Documents. 

  

Click the desired program plan and contract plan to be linked. 

  

Click Link . 

  

The contract plan is now associated with the program plan. 

  

In the example below, the program plan and the last contract plan displayed are meant to be 

linked. 

  

Before Linking:  

  

 

  



Tutorials 

27 

  

After Linking:  

  

      

 

  

The second contract plan is now linked under the program plan. 

  

Tip: Subcontract plans can also be linked to contract plans. Similarly, a 1921 can be 

linked to a contract plan, and a 1921-1 can be linked to a 1921. 

  

Situations where this tool might be useful are listed below: 

  

a) If a contract plan was imported under the wrong program plan, the linking tool allows the 

contract plan to be matched up with the correct program plan. 

  

b) If a program plan was re-imported since the original import, the contract plans will no 

longer be connected to the program plan. The linking tool allows for re-association. 
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Tip: Contract plans can also be rearranged in the main window of cPet by dragging and 

dropping one plan onto another. In the example below, the contract plan is being moved 

under the program plan. The yellow arrow  points to the document under which the 

contract plan will be indented. 

  

 

  

  

2.1.8 CONVERTING PLANS  TO 2011 VERSION 

If you have already imported a plan in the 2003 or 2007 version but would like to view it in 

the 2011 format, click Tools > Convert to 2011 version on cPet's main window. This 

command can also be accessed through the  icon. 

  

To convert a plan to the 2011 version... 

  

1. Select the plan (program, contract, or subcontract) in the main window of cPet. 

2. Click Tools > Convert to 2011 version. 

3. You will be asked where you want to save the XML version of the new plan. The plan will 

be saved with a default name of "[Plan name] -- 2011 Version." 
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4. Once you save the plan, the plan displayed in cPet will be the 2011 version. 

5. If you would like to view the old version again, you must reopen it from its original saved 

location. 

  

All the information will be copied over. However, you should note the following nuances: 

  

When converting from 2003 to 2011: 

A few fields will be added to the Basic Info (such as the Prime Mission Product). Some 

fields (such as the Approved Plan Number/Review&Ref #) are renamed but contain the same 

information. 

The Contract Information tab of the Basic Info will have additional fields for the 

Appropriation and the Required Reports on the 2011 version. 

The 1921 and 1921-1 columns for the WBS Editor and the Submission events have slightly 

different names, but they basically correspond 

The 2630 column in the WBS Editor of the 2003 version is now called the SRDR column 

in the 2011 version 

The CWBS Dict. column is added to the WBS Editor for the 2011 version. The checkboxes 

in the column will be checked for all elements 

The 1921-4 column will be added to the WBS Editor and the Submission events of the 

2011 version. The checkboxes in this column will be unchecked by default. 

In the Submission Events, the 2630-2 and 2630-3 columns are now called the SRDR Initial 

and SRDR Final columns, respectively, in the 2011 version 

The summary elements for contract plans are slightly different 

  

When converting from 2007 to 2011: 

One column will be added to the WBS Editor and the Submission events of the 2011 

version: 1921-4. The checkboxes in this column will be unchecked by default. 

The Contract Information tab of the Basic Info will have additional fields for the 

Appropriation and the Required Reports on the 2011 version. 
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Tip: Cost reports in the 2007 version can also be converted to the 2011 version. 

  

2.1.9 IMPORTING ERRORS TO AVOID  

The following is a list of common errors that may occur when importing a plan. These errors 

most often occur because the DD 2794 was improperly formatted; a problem that can be 

resolved by following the sample DD 2794, or by editing the fields in cPet. Most of these 

errors are recorded in the Conversion Results, while some are highlighted within cPet. 

  

1. Weapon System Type must be a valid MIL-HDBK-881 specification (e.g. "Aircraft 

System"). 

  

2. cPet may not import Milestone or Submission Type formulas from the Excel file. For 

example, cPet may not recognize a formula such as "IF ('Main Sheet'!C4="B","X","")" that is 

used to identify Milestone B. 

  

3. A WBS item will be highlighted if it is an only child (see below).  The color of the 

warning depends on the Display Colors in the cPet Options. 

  

 

  

Note that an element will also be flagged if it is the only item at that level that has reports 

checked. For example, in the image below, the Telemetry element is highlighted because it is 

the only element at its indenture level that has forms checked. The Integration element shows 

"N/A" and has no forms checked. 
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4. A WBS item will be highlighted if it does not have any columns (not including the CWBS 

column) checked. 

  

5. WBS element indenture level will be determined by the WBS indentation structure in the 

Excel file (as opposed to the WBS item numbers themselves). In the example below, 

"Complete Round" is mistakenly put at the same level as "Ordnance System." cPet will 

mimic this structure and ignore the actual WBS Item Numbers when displaying elements in 

the WBS Editor. 

  

 

  

  

 

  

  

6. Submission event headers will be highlighted (see below). The color of the warning 

depends on the Display Colors in the cPet Options. 
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7. Submission event dates marked as N/A or dates that are invalid will be left blank in cPet 

and highlighted. 

  

Tip: Invalid dates such as 4/31/2007 will not import (April has only 30 days). 

  

8. The Address must be on the correct line in the Excel file in order to import correctly. See 

below for incorrect and correct formatting. Note that cPet tolerates different 2007 address 

formats better than 2003 formats. 

  

2003 Plans 

Incorrect: 

  

 

  

 

  

Correct: 
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2007 and 2011 Plans 

Incorrect: 

  

 

(as a merged cell) 

  

Correct: 

  

 

(as a merged cell) 
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(if not merged) 

  

  

9. In the Form field of the submission events, the text must be written in the correct format 

(see below). 

  

2003 Plans 

  

¶ The submission event form 2630 must have a part specified. 

  

Incorrect: 2630 

Correct: 2630-2, 2630-3 

  

If "2630" is written on the Excel file, cPet will check both parts in the submission 

events. 

  

2007 and 2011 Plans 

  

¶ The CWBS Dictionary must be written as follows: 

  

Incorrect: WBS Dictionary, WBS Index 

Correct: CWBS Dictionary 

  

¶ The submission event form 2630 is recognized as follows: 
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2630-2 is equivalent to SRDR Initial 

2630-3 is equivalent to SRDR Final 

  

Note: If "2630" is written on the Excel file, cPet will check both parts (SRDR Initial 

and SRDR Final) in the submission events. 

  

¶ Cost reports may be formatted as follows: 

  

1921-1, 1921-1 Part 1, 1921-1 Part I, 1921-2, 1921-1 Part 2, 1921-1 Part II, 1921-4 

  

10. Excel formatting must resemble that of the original DD Form 2794. If the border around 

a cell(s) is missing, the file may not import at all, or part of the data may not import. In the 

example below, the borders are lacking on the CWBS Dictionary column. WBS elements 

corresponding to the unformatted rows will not import into cPet. 

  

Incorrect: 
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Correct: 

  

 

  

  

  

2.2 CREATING PLANS  

2.2.1 CREATING A PROGRAM P LAN  

2.2.1.1 Creating a Program Plan 

The process of creating a program plan is similar to that of importing a program plan in that 

there are three main components: the Basic Information, WBS Editor, and Submission 

Events. However, whereas you could simply review these components when importing a 

plan, you must manually fill in information when creating a plan. The last tutorial in this 

section, Building the RDT, will be useful later when the contract plan is created. 

  

To start creating a program plan, complete this tutorial and then proceed to Editing the Basic 

Information and continue to follow the rest of the tutorials listed below. 

  

Editing the Basic Information 

Editing the WBS 

Editing the Submission Events 

Building the RDT 
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In the main window of cPet, click File > New > New Program Plan, or just click  

 on the main toolbar. 

  

 

  

The Create Program Plan dialog pops up. Choose whether you would like to create 

a new plan from scratch, or to copy an existing plan open in cPet. 
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In this tutorial, we will create a new plan and use the 2011 format, as new plans 

should typically be created using the most recent version. 

  

The Basic Info dialog appears. Continue to Editing the Basic Information to fill in the 

program plan. 

  

2.2.1.2 Editing the Basic Information 

  

This tutorial is step one in the three-step process of creating a program plan: 

  

­ 1. Edit the Basic Information 

     2. Edit the WBS 

     3. Edit the Submission Events 

  

The Basic Information window appears after File > New > New Program Plan is 

clicked. Fill in this window with the appropriation information. Note that changing the 

WBS System Type from MIL-STD-881C to MIL-HDBK-881A affects the values in the 

WBS System Type dropdown. 
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Tip: See the Basic Info Dialog for more information on what the fields correspond 

to on the DD Form 2794. 

  

Fill in information in the DD2794 Narrative Text tab. Use the following icons to add 

headings: 

  

Add a new parent heading 

Add a new sibling heading 

Add a new child heading 

Move entry up on the list 

Move entry down on the list 

Delete the heading 
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Save and close the Basic Info window. 

  

Tip: The "proper" way to organize the Narrative Text is to have a parent header, followed 

by a child header, followed by the actual descriptive text. For instance, the layout of the 

Narrative Text should be as follows: 

  

Parent Header 

Child Header 

Descriptive Text 

  

Do not type information directly under the first two headers. If you do not follow the above 

layout, the text will not be properly formatted in the Remarks section when exported to PDF 

or Excel. 

  

Move on to Editing the WBS Editor to continue creating the plan. 

  

  

2.2.1.3 Editing the WBS 

This tutorial is step two in the three-step process of creating a program plan: 

  

     1. Edit the Basic Information 

­ 2. Edit the WBS 

     3. Edit the Submission Events 

  

In the main window of cPet, click  to view the WBS Editor. 

  

Depending on whether or not "Prompt before providing WBS structure to plans with 

no WBS" is checked in the Options, cPet may or may not automatically fill in the 

WBS Editor. If this option is not checked, then the WBS elements corresponding to 

the program plan's Weapon System Type will appear in the WBS Editor (in this 
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tutorial, these are the elements for a Space System). If this option is checked, you 

will be asked whether or not you want the WBS Editor to be filled in automatically. 

  

Tip: Setting the standard WBS type to MIL-HDBK-881A or MIL-STD-881C affects 

how the WBS elements are auto-populated. 

  

Fill in the required forms next to each WBS element. 

  

 

  

Tip: The four rows which are highlighted pink in the example above indicate that 

there is an error. See Errors to Avoid for more details. In this particular example, 

they are pink because there must be at least one column checked (not including the 

CSWB Dict. column). 

  

Use the following icons to check/uncheck items and to add, edit, or move elements: 

  

Undo 

  

Redo 
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Add a sibling to the selected element 

  

Add a child to the selected element 

  

Delete an item 

  

Copy a WBS element 

  

Cut a WBS element 

  

Paste a WBS element (note that elements can be pasted into cPet or into Excel) 

  

Indent an item 

  

Unindent an item 

  

Move an item up in the list 

  

Move an item down in the list 

  

Provides the option of assigning a WBS number to each item, or clearing the item 

numbers 

  

Free Edit Mode - Turn on Free Edit mode to add, delete, or arrange WBS 

elements easily. See below for more details 
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Expand All (Found under the View Menu)- All the elements in the WBS tree will 

be displayed 

  

Collapse All (Found under the View Menu)- All the elements in the WBS tree will 

be collapsed so that only the root element(s) is displayed 

  

Check (Found under the Edit Menu) - Use the shift or control key to select a few WBS 

items in a certain column. Then click this icon to check all the items in the selection 

  

Uncheck (Found under the Edit Menu) - Use the shift or control key to select a few WBS 

items in a certain column. Then click this icon to uncheck all the items in the selection 

  

Insert Standard WBS (Found under the Edit Menu). Provides the option to insert one of 

the standard WBS's according to either the MIL-HDBK-881A or MIL-STD-881C as 

specified. 

  

To check/uncheck all the elements in a column, right click on the column header and select 

 or  , respectively. 

  

Tip: From the Edit menu, you can Select All or Select Child Elements. These commands 

can be particularly useful if you would like to delete groups of elements from a standardized 

WBS. 

  

Tip: Elements can be copied from the WBS Editor and pasted into Excel. Likewise, 

elements can be copied from Excel and pasted into the WBS Editor. 

  

Tip: Click Edit>Insert WBS from Existing Plan to add WBS elements from a selected 

plan already open in cPet. 
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Free Edit Mode 

  

The Free Edit Mode may be useful when creating new WBS elements or rearranging the 

indentation structure of the elements. Click the icon on the toolbar to turn on 

the Free Edit Mode (the button will turn orange). In Free Edit Mode, parent/child 

relationships among WBS elements are relaxed so that individual elements can be indented 

and moved without changing the indentation or position of other elements. The WBS 

elements will still appear indented under each other, but the Expand () and Collapse ( ) 

icons will no longer be present. The purpose of the Free Edit Mode is to visually organize the 

WBS with ease. Without this mode turned on, a newly added element may not appear where 

you would like it to be in the tree structure. 

  

There are a few things to note when using the Free Edit Mode: 

  

After changing the WBS in Free Edit Mode, the WBS indenture structure will be 

maintained after the mode is turned off. 

WBS elements are indented by four spaces. However, if you indent an element by a single 

space, cPet will interpret this element as being indented by four spaces. 

If you indent an element by more than four spaces, cPet will ignore these extra spaces. If 

you close and reopen the WBS Editor, the element will appear indented by the normal four 

spaces. 

  

Continue to Editing the Submission Events to create the next component of the plan. 

  

  

2.2.1.4 Editing the Submission Events 

This tutorial is step three in the three-step process of creating a program plan: 

  

     1. Edit the Basic Information 

     2. Edit the WBS 
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­ 3. Edit the Submission Events 

 

In the main window of cPet, click  to open the Submission Events: 

  

Use the toolbar at the top of the window to add and edit submission events. A brief 

explanation of the toolbar is given below. 

  

 

  

  

Delete a submission event 

  

Use the shift or control key to select a few submission events in a certain column. 

Then click this icon to check all the items in the selection. 

  

Use the shift or control key to select a few submission events in a certain 

column. Then click this icon to uncheck all the items in the selection. 

  

Add submission event(s). 

  

Add Type ï Adds either ñBlankò or ñLike Currentò events 

  

ñBlankò = Adds new rows 

ñLike Currentò = Copies rows from selected row 
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Fill Down Value ï When several rows are selected, clicking this icon 

checks/unchecks the boxes in the column according to the first row. This icon can 

also be used to copy dates down a column. 

  

Fill Down Date Value ï When multiple rows are selected, clicking this icon 

generates dates down the column. These dates are set apart from each other by a 

certain increment of time. 

  

Insert a row before the selected event (found on Edit menu) 

  

Insert a certain number of rows (quantity depends on numerical value in toolbar; 

found on Edit menu) 

  

Add a row to the end of the submission events list (found on Edit menu) 

  

Add a certain number of rows to the end of the submission events list (quantity 

depends on numerical value in toolbar; same as  icon; found on Edit menu) 

  

Sort and Renumber ï Arranges the submission events by As of Date and 

designates an Event Number for each. 

  

Import Events from contract plan - Contract plan submission events can be 

imported into a program plan's submission events. See Import Events from Contract 

Plan for more information. Icon found under the Tools menu of a program plan. 
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To check/uncheck all the events in a column, right click on the column header and select  

or  , respectively. 

  

Tip: From the Edit menu, you can Select All. This command can be particularly useful if 

you would like to either check/uncheck all the submission events, or delete them all. 

  

For practice, use the icons above to add events according to the image below. 

  

 

  

  

Tip: Notice that the dates for Events #2-5 are distributed every three days. Make 

use of the Fill Down Dates icon to easily complete this exercise. 

  

Tip: Use the multi-check icon to check CWBS Dict. for Events #1-3. 

  

Tip: Once an As Of Date is assigned to a submission event, cPet automatically 

generates a Due Date, but this date can easily be changed. 

  

Save and close the Submission Events. 

  

You have now finished creating a program plan. Proceed to Building the RDT to 

understand how to create and export a plan's RDT in cPet. 
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2.2.1.5 Building the RDT 

After a program plan is created, the next step is to build the Resource Distribution Table 

(RDT). It is not necessary to build an RDT in cPet, but an RDT typically accompanies a 

program plan. The RDT can be used to build new contract plans. See WBS Editor of a 

Contract Plan for more information. 

  

In order to view the RDT, at least one contractor must first be chosen. Click on the 

Contractor Selection icon . 

  

In this tutorial, we will select two contractors: 

  

1) *Demo* ABCD Corporation 

2) Sample Contractor 

  

Find these contractors and click ñAdd.ò You might try using the filter feature to search for a 

few key words. Note that if a contractor is absent from the Contractor Selection list, you can 

add it through the Contractor Maintenance. 

  

Tip: For a detailed description of how to add contractors, see the Contractor Selection 

Dialog. 

  

After the contractors are chosen, select the parent plan and click the RDT icon  in the 

main window of cPet (or click View>RDT). 

  

WBS Elements 

The RDT is designed to allocate responsibility to each contractor for every WBS element. 

  

Check which contractor is responsible for which WBS elements. In this tutorial, *Demo* 

ABCD Corporation is responsible for items ñSpace Systemò and ñSEIT/PM and Other 
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Common Elementsò as well as ñGround (1...n as required) through ñLaunch Vehicleò (the 

last WBS element is not shown in the image below). 

  

 The Sample Contractor is responsible for ñSpace Systemò and ñSpace Vehicle (1...n as 

required)ò through ñLaunch Operations & Mission Support.ò 

  

 

  

Use the toolbar at the top of the RDT window to easily check or uncheck items. 

  

  

Check Selection - Use the shift or control key to select a few WBS items in a certain 

column. Then click this icon to check all the items in the selection. 

  

Uncheck Selection - Use the shift or control key to select a few WBS items in a certain 

column. Then click this icon to uncheck all the items in the selection. 

  














































































































































































































































































































